Función sumaproducto

Entrada núm: 6 of 16 de la serie Análisis de datos

Funciones integradas SUMAPRODUCTO y SUMAR.SI

La función SUMAPRODUCTO es capaz de realizar tareas con un alto nivel de demanda en Excel. En el ejemplo que acompaña a este artículo necesitamos averiguar el acumulado de unas determinadas cantidades siempre que se cumpla una condición. La solución natural podría venir de mano de la formula SUMAR.SI(…). Pero nuestro objetivo, además de no sobrecargar la hoja con demasiadas fórmulas, es aprender el uso de la función SUMAPRODUCTO.

{\color{Magenta} =SUMAPRODUCTO(--(A2:A27=E1);C2:C27)}

Código VBA

Colocamos el código en un módulo independiente y lo activamos de dos formas distintas: mediante el click de un botón y mediante el evento SelectionChange del objeto Worksheet. El código es el siguiente:

Eventos de hoja

Os recuerdo que siempre es preciso ser extremadamente cuidadosos cuando colocamos código asociado a los eventos del objeto HOJA, especialmente si ese código incluye el paso por algún bucle o algún tipo de iteración, ya que en caso de que nos hayamos equivocado y el programa entre en un bucle sin salida, no tendremos más remedio que forzar la finalización de Excel. Por tanto la medida de prudencia mínima sería.

Series Navigation<< Media móvil con DESREF y CONTARACOINCIDIR e INDICE para buscar datos >>

Comments

This post currently has 2 responses

Deja tu comentario aquí:

Sidebar



A %d blogueros les gusta esto: